Настройка PXE-сервера

Опишу возможность использования устройства Mikrotik для создания сервера сетевой загрузки. Процесс настройки крайне прост и может быть выполнен в течение 5-10 минут. В данном примере будем в качестве диска для загрузки будем использовать минимальный установочный диск Ubuntu Netboot 12.04. В общем же случае размер загружаемого по сети дистрибутива ограничен следующими параметрами:

  1. размером памяти на клиентской машине: загружаемый диск должен полностью поместиться в оперативной памяти компьютера. Также еще должно остаться место для выполнения самой установки;
  2. размером свободной дисковой памяти на mikrotik: для роутеров 951 и 2011 серий обычно достаточно внутренней памяти для большинства задач. При необходимости можно использовать usb-флешку, но надо учесть, что загрузка с нее будет идти примерно раза в 2 медленнее.

Итак, для настройки PXE-сервера на mikrotik делаем следующее:

  1. Загружаем http://www.ansealk.ru/files/tftp-mikrotik.zip и распаковываем в любой каталог;
  2. Если не хотите менять загрузочное меню - переходите сразу к п.4. Редактируем файл tftp/bootmsg, например добавляем строку с еще одним вариантом загрузки. Это обычный текстовый файл, который будет выводится на экран перед выбором варианта загрузки.
  3. Если не хотите менять загрузочное меню - переходите сразу к п.4. Редактируем файл tftp/pxelinux.cfg/default. Файл содержит описание того, что делать при выборе определенных пунктов меню. При необходимости указания дополнительных параметров можно обратиться к документации по pxelinux.
  4. Скопируйте каталог tftp в корневой каталог роутера
  5. Подключитесь терминалом к роутеру и настройте TFTP-сервер:
    /ip tftp
    add ip-addresses="172.16.0.0/24" real-filename=tftp/pxelinux.0 req-filename=pxelinux.0
    add ip-addresses="172.16.0.0/24" real-filename=tftp/bootmsg.txt req-filename=bootmsg.txt
    add ip-addresses="172.16.0.0/24" real-filename=tftp/memdisk req-filename=memdisk
    add ip-addresses="172.16.0.0/24" real-filename=tftp/pxelinux.cfg/default req-filename=pxelinux.cfg/default
    add ip-addresses="172.16.0.0/24" real-filename=tftp/mini.iso req-filename=mini.iso 
    

    172.16.0.0/24 - внутренняя сеть.

  6. Укажем файл загрузки в DHCP-сервере(он уже должен быть настроен)
    /ip dhcp-server network
    set [find address="172.16.0.0/24"] boot-file-name=pxelinux.0 next-server="172.16.0.1"
    

    172.16.0.0/24 - внутренняя сеть.
    172.16.0.1 - адрес tftp-сервера.

На этом настройка закончена. Вы можете проверить как работает ваш PXE-сервер перезагрузив компьютер и включив загрузку по сети.

nastrojka_pxe-servera.txt · Последние изменения: 2013/12/23 16:32 (внешнее изменение)
GNU Free Documentation License 1.3
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0 Яндекс.Метрика