IPv6 на Mikrotik

Рассмотрю только вариант при следующих вводных:

  1. Провайдер не поддерживает IPv6;
  2. У меня подключен публичный статический IPv4 адрес - в данной статье для примера используется адрес 123.45.67.89;
  3. Из Вашей сети доступен адрес 192.88.99.1 - проверяем просто пингом;
  4. На маршрутизаторе включен пакет ipv6.

В описании буду давать два варианта насторйки - через терминал и через winbox

Добавим адрес туннеля 6to4tunnel

В Winbox выбираем Interface → Add interfacee → 6to4tunnel и выставляем следующие параметры (не забудем заменить адрес 123.45.67.89 на Ваш):

В консоли это можно сделать командой:

/interface 6to4 add name=ipng disabled=no local-address=123.45.67.89 remote-address=192.88.99.1 mtu=1280

Сформируем переходный IPv6-адрес для туннеля

Формируется данный адрес следующим образом:

  1. Переводим наш внешний IPv4 в шестнадцатеричную запись. В результате получим 7B.2D.43.59 (для адреса 123.45.67.89);
  2. Запишем получившееся число в таком формате: 7B2D:4359;
  3. Подставим префикс и разрядность: 2002:7B2D:4359::/64. Получившийся префикс будет присутствовать у всех устройств Вашей сети.

Если не охота считать - можете, например, зайти на ресурс https://6to4.version6.ru/ и сделать преобразование там.

Добавим адрес на маршрутизатор

IPv6 → Addresses → Add:

В консоли:

/ipv6 address add address=2002:7B2D:4359::1/16 advertise=no comment=6to4public disabled=no eui-64=no interface=ipng

Проверим, что в тамбице маршрутизации появился динамический маршрут 2002::/16 со шлюзом ipng:

[xxxxx@xxxxxxxx] > ipv6 route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable 
 #      DST-ADDRESS              GATEWAY                  DISTANCE
 0 ADC  2002::/16                ipng                            0

Создадим сеть для Ваших устройств

IPv6 → Addresses → Add:

В консоли:

/ipv6 address add address=2002:7B2D:4359:1::1/64 advertise=yes comment=6to4subnet disabled=no eui-64=no interface=bridge1

Для этой сети можете настроить DHCPv6 или ND - тут я пока не рассматриваю данный вопрос.

Пропишем маршрут по-умолчанию

IPv6 → Routes→ Add:

В консоли:

/ipv6 route add gateway=ipng  type=unicast distance=1 scope=30 target-scope=10

В результате у нас должна быть следующая таблица маршрутизации:

[xxxxx@xxxxxxxx] > ipv6 route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, o - ospf, b - bgp, 
U - unreachable 
 #      DST-ADDRESS              GATEWAY                  DISTANCE
 0 A S  ::/0                     ipng                            1
 1 A S  2000::/3                 ::192.88.99.1%ipng              1
 2 ADC  2002::/16                ipng                            0
 3 ADC  2002:7B2D:4359:1::/64    bridge1                         0

Настройка DNS

Добавим публичные DNS-сервера Google

  • 2001:4860:4860::8888
  • 2001:4860:4860::8844

IP → DNS:

Проверка работоспособности

Теперь у нас без проблем должны работать пинги на адреса IPv6

ping 2001:4860:4860::8844

и резолвится имена

ping [:resolve ipv6.google.com]

Также можно попробовать зайти браузером по адресам

  • test-ipv6.com
  • ipv6.nic.ru

Послесловие

Мы настроили на маршрутизаторе сеть IPv6 как на внешнем, так и на внутреннем интерфейсе. Не забываем после этого настроить фаервол, так как все устройства, получившие адрес IPv6 будут доступны извне сети!!!

ipv6_na_mikrotik.txt · Последние изменения: 2018/06/03 22:17 — adm1n
GNU Free Documentation License 1.3
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0 Яндекс.Метрика