Быстрый запуск

I. Первый запуск на примере Mikrotik RB751u-2Hnd.

  1. Перед подключением роутера желательно скопировать MAC-адрес компьютера (или роутера), к которому напрямую подключен интернет.
    Скопируйте или запишите все настройки текущего интернет соединения.
    • Для Static IPIP адрес, Шлюз, ДНС-сервера.
    • Для PoE, PPTP, L2TP – дополнительно логин, пароль, адрес VPN-сервера.
  2. MAC-адрес и все настройки сети можно посмотреть командой
    ifconfig         # для linux
    ipconfig /all    # для windows
    
  3. Также желательно сразу скачать последнюю прошивку под Ваш Микротик с сайта http://mikrotik.com. Раздел Download. Выбирам нашу серию - 700. Скачиваем файл с расширением .npk. Тут же можно скачать zip – архив с доп. модулями и WinBox.exe.
  4. Рекомендуется сделать Ресет(сброс на заводские настройки), если настройки роутера раньше менялись. Выключаем питание, ручкой зажимаем и держим ресет, включаем питание, держим ресет еще 20 сек. Пока не заморгает и снова не загорится сзади Лампочка Act.
  5. Подключаем роутер. Один конец витой пары в комп. Другой в порт №2 на роутере. Если Вы уже скачали Winbox – можете перейти к п. 7.
  6. RB750 на портах №2-5 по умолчанию имеет IP-адрес 192.168.88.1. Поэтому:
    1. меняем IP-адрес сетевой карты на компе на 192.168.88.2, маску подсети 255.255.255.0.
    2. Заходим на web-страницу роутера http://192.168.88.1.
    3. Скачиваем оттуда WinBox.exe
  7. Запускаем WinBox.exe.
    1. Кликаем по кнопке, что справа - […].
    2. Далее по MAC-адресу нашего роутера. (В WinBox можно заходить по MAC-адресу или IP роутера). Нажимаем кнопку [Connect] и попадаем в WinBox интерфейс.
    3. Должна появиться табличка. Кликаем [OK]. Все настройки останутся по умолчанию. [Remove Configuration] - удалит все дефолтные настройки роутера.
    4. Совет: Перед серьезными изменениями на роутере делайте бэкап настроек Files –> Backup. Не забывайте также про кнопки Undo-Redo и Safe Mode.
  8. Рекомендую сразу прошить роутер на последнюю прошивку.
    1. Перетаскиваем мышкой на WinBox наш .npk файл прошивки.
    2. Перезагружаем роутер. Ждем пока он прошьеться. 2-3 мин. Не отключайте питание!.
    3. После прошивки роутер сам удалит наш файл. Все настройки роутера микротик сохранятся.
  9. Начиная с версии 5.15 - появился раздел Quick Set - быстрая настройка. Все основные базовые настройки можно сделать на этой одной странице. Тут можно поменять также MAC-адрес WAN-порта, настроить WAN, LAN (Static IP, Dynamic IP, PPPoE) и даже WiFi. Пока нет только PPTP, L2TP и Dual Access. Но настоятельно рекомендую настроить вручную. Для понимания - что и зачем.

II. Смена MAC

  1. Смена MAC-адреса. Это самое первое, что всегда нужно делать при подключении к провайдеру.
    1. Кликаем - [New Terminal]. Вводим:
      /in et set 0 mac="00:11:22:33:44:55"
      или
      /interface ethernet set ether1-gateway mac-address=00:11:22:33:44:55
      

      00:11:22:33:44:55 – это наш скопированный MAC-адрес (можно взять со старого роутера ил компьютера). *0* — Это порт роутера №1.

    2. Теперь кабель провайдера тыкаем в порт №1. Если у Вас все на автомате (Dynamic IP) – то интернет уже должен быть и ничего настраивать больше не нужно.
  2. Также можно переименовать интерфейсы. Кликаем Interfaces.
    1. Двойной клик по интерфейсу №1, меняем название на WAN1.
    2. Двойной клик по интерфейсу №2, меняем название на LAN1.

III. Подключаемся к провайдеру

  1. Тут возможны следующие варианты:
    1. Динамический IP. (На автомате. DHCP-клиент включен)
      Итак, у Вас настройки от провайдера приходят на автомате. По умолчанию DHCP-клиент должен быть уже включен.
      1. Для проверки кликаем: IP –> DHCP Client.
      2. В строчке IP Address – должен быть IP -адрес, полученный от провайдера. Если такой строчки нет — то кнопкой [+] создаем запись с номером порта №1.
      3. Двойной клик по этой строчке. Далее Status. Тут видим все настройки, полученные от провайдера. IP, Шлюз, DHCP сервер, DNS.
      4. В IP –> Routes – должны появиться маршруты от провайдера (с буквой D – Dynamic)
      5. В Address list – Должна быть динамическая запись - с IP адресом порта №1, полученные от провайдера.
      6. Переходим к п. 2.
    2. Статический IP (DHCP-клиент отключен)
      Итак, у Вас IP нужно прописывать вручную.
      1. Идем в IP –> DHCP Client. Отключаем или удаляем DHCP запись.
      2. Переходим во вкладку IP → Address List.
      3. Кликаем [+] и добавляем - 178.11.22.33/24, 178.11.22.0, интерфейс WAN1.
        178.11.22.33 — Ваш IP-адрес_выданный_провайдером
        24 – это то же самое, что 255.255.255.0 — маска подсети
      4. В IP –> Routes – должны появиться маршруты от провайдера.
      5. Переходим к п. 2.
    3. PPPoE. По логину и паролю
      1. Вначале делаем при необходимости все по п. 1.a. или 1.b.
      2. Кликаем PPP. Кнопка [+] → PPPoE клиент.
      3. Вкладка General. В Interfaces выбираем наш WAN1.
      4. Вкладка Dial Out. В User и Password вводим логин и пароль от провайдера.
      5. Add Default Route - включить
      6. Выбираем профиль default или default-encryption.
        При необходимости меняем наш профиль во вкладке профили.
      7. Далее Apply. Кнопкой Disable-Enable – включаем наш PPPoE.
      8. Внизу справа появится Status: Connected.
      9. Во вкладке Interface — должна быть запись PPPoE клиента.
      10. В IP –> Routes – наблюдаем динамические маршруты от провайдера.
      11. Переходим к п. 2.
    4. PPTP, L2TP. VPN по логину и паролю
      1. Вначале делаем все по п. 1.a. или 1.b.
      2. Кликаем PPP. Кнопка [+] → PPTP клиент. L2TP — аналогично.
      3. Вкладка Dial Out → Connect to: адрес VPN-сервера.
      4. В User и Password вводим логин и пароль от провайдера.
      5. Add Default Route - включить.
      6. Выбираем профиль default или default-encryption.
        При необходимости меняем наш профиль во вкладке профили.
      7. Далее Apply. Кнопкой Disable-Enable – включаем наш PPTP.
      8. Внизу справа появится Status: Connected.
      9. Во вкладке Interface — должна быть запись PPTP клиента.
      10. В IP –> Routes – наблюдаем динамические маршруты от провайдера.
      11. Переходим к п. 2.
    5. PPTP, L2TP Dual Access.
      1. Вначале делаем все по п. 1.a. или 1.b.
      2. Если у Вас Dual Access и наблюдаются обрывы каждую минуту, то открываем New Terminal:
        /ip route
        rule add act=lookup dst-a=10.128.4.71/32 ta=matrix_vpn
        add dist=1 dst-a=10.128.4.71/32 ga=10.0.137.1 routing-mark=matrix_vpn
        add dist=1 dst-a=0.0.0.0/0 ga=10.128.4.71

        10.128.4.71 — это адрес VPN-сервера.
        10.0.137.1 - это шлюз, полученный от провайдера по DHCP.

      3. Далее Делаем все по п. 1.d. Единственное, что PPTP клиенте Add Default Route – выключить. А в Connect to: такой же адрес VPN-сервера, что и выше.
      4. Переходим к п. 2.
  2. Настраиваем DNS. Проверяем сеть и DNS с помощью Ping.
    1. Идем в IP –> DNS. Там должны быть уже прописаны DNS-ы.
    2. Если их нет, то прописываем в DNS Servers наши DNS от провайдера.
    3. Allow Remote Request – включаем.
    4. Идем в Tools –> Ping.
    5. Пингуем сначала адрес 8.8.8.8. Если пингуется значит коннект есть.
    6. Затем пингуем ya.ru. Если пингуется, значит DNS настроены верно.
  3. Время на роутере.
    1. System –> SNTP Client. Enabled. Unicast.
    2. В Primary NTP Server и Secondary NTP Server – вписываем сервера времени. К примеру ts1.aco.net. В Last Update появится 00:00:02 ago.
    3. Идем в System –> Clock. Выбираем наш регион, например Europe-Kiev. Apply. Все. Время теперь установлено верно.

IV. Настраиваем локальную сеть.

Для начала нужно определиться какой сегмент сети Вы хотите использовать. По умолчанию на роутере на порту №2 (наш LAN1) стоит 192.168.88.1. Допустим мы хотим поменять на сегмент сети 192.168.0.0/24. Сегмент сети — должен отличаться от сегмента провайдера

  1. Статический IP у клиентов. В данном режиме клиенты IP адреса от роутера получать не будут.
    1. Пропишите у клиентов на компах адреса вида 192.168.0.ххх, маску подсети 255.255.255.0, Шлюз и DNS 192.168.0.1.
    2. В IP –> Address List откроем запись на порту LAN1, изменим все записи 192.168.88.ххх на 192.168.0.ххх. Если такой записи нет — то создайте ее. Адрес порта LAN1 на роутере – 192.168.0.1/24
    3. В IP –> DHCP Server → Networks отключаем или удаляем запись DHCP.
    4. Во вкладке DHCP также отключаем или удаляем запись DHCP.
  2. Динамический IP у клиентов. Выдача IP по MAC.
    1. В IP –> Address List откроем запись на порту LAN1, меняем все записи 192.168.88.ххх на 192.168.0.ххх. Если такой записи нет — то создайте ее.
    2. В IP –> DHCP Server → Networks меняем все записи 192.168.88.ххх на 192.168.0.ххх. В DNS прописать IP роутера - вида 192.168.0.1
    3. В IP –> DHCP Server –> вкладка DHCP –> кликаем по записи. Смотрим название Address Pool – например это dhcp_pool1.
    4. Идем в IP→Pool – меняем в dhcp_pool1 все записи 192.168.88.ххх на 192.168.0.ххх. Можно указать диапазон IP адресов, которые будут выдаваться клиентам.Можно просто грохнуть 2 записи в DHCP и нажать DHCP setup, настроив DHCP заново. Не забудьте настроить IP→Pool.
  3. Блокировка левых MAC+IP. Для того, чтобы включить блокировку левых MAC и IP нужно:
    1. В IP –> DHCP Server –> Leases – сделать все записи статическими. По умолчанию все записи создаются динамически. Имеют букву D слева.
    2. Двойной клик по записи → Make StaticОк. Можно также прописать желаемый IP-адрес клиенту.
    3. В IP → ARP - по умолчанию все записи динамические (с меткой D).
    4. Тоже делаем двойной клик по записи и Make Static.
    5. Важно! Ваш MAC-адрес и IP-адрес должен быть в списке! Иначе Вы не сможете зайти в WinBox.
    6. Идем в Interfaces. Два раза кликаем по интерфейсу LAN1, на котором сидят клиенты. В опции Arp выбираем Reply-only. Теперь при смене MAC или IP, или подключении левого пользователя — интернет и доступ к сети они не получат.

V. Настраиваем WiFi на раздачу. Режим обычного роутера.

  1. Кликаем Wireless. Там должна быть запись Wi-Fi интерфейса. Если ее нет — добавляем кнопкой [+].
  2. Кликаем Advanced Mode.
  3. Выбираем Mode: AP Bridge. SSID – Имя нашей WiFi точки.
    1. Band: ставим желаемый режим работы WiFi.
    2. Channel Widh: ширину канала. Обычно — 2GHz-B/G/N,20/40MHz HT Below — режим совместимости. Если нужен расширенный диапазон частот - Frequency mode: Superchannel.
    3. Frequency: ставим желаемую частоту. (Учитывайте, что ноутбуки работают только на стандартных частотах)
    4. Security Profile:Default (В этом профиле мы затем укажем WPA пароль)
    5. Bridge Mode: включен.
    6. В Data Rates выбираем режимы работы.
    7. В HT Включаем — Chain 0, antenna a. (Chain 0, Chain1 – только для MIMO)
    8. Для ноутбуков WDS, Nstream, NV2 – должен быть отключен.
    9. Pooling — оставить включенным.
    10. В TX Power можно выставить мощность передатчика.
    11. Жмем Apply. Enable. Внизу справа должно появиться — running ap.
  4. Не забудьте отредактировать профиль в Security Profiles и поставить WPA пароль для доступа к точке.
    1. Идем во вкладку Security Profiles.
    2. 2 раза кликаем по Default.
      1. Mode: dynamic keys.
      2. WPA PSK, WPA2 PSK, tkip, aes com — включаем.
    3. WPA Pre-Shared Key, WPA2 Pre-Shared Key – ставим наш пароль из 8 символов.
    4. Management Protection: disabled.
  5. При желании можно добавить любое количество WiFi точек с разными SSID (Wireless –> Interfaces → [+] Virtual AP).
  6. Теперь идем в IP –> Address List. Добавляем запись c IP: 192.168.2.1/0, 192.168.2.0, Интерфейс wlan1.
  7. Интернет уже будет, если на Wi-Fi адаптере компьютера поставить IP 192.168.2.2, Маску 255.255.255.0, Шлюз 192.168.2.1, DNS 192.168.2.1.
  8. Для получения IP по DHCP есть 2 варианта:
    1. Добавить еще один DHCP-сервер на порт wlan1 с пулом адресов 192.168.2.ххх.
    2. Сбриджевать интерфейсы локалки и WiFi:
      1. Идем в раздел Bridge.
      2. [+] - добавляем интерфейс bridge1.
      3. Тут же кликаем Settings → Use IP Firewall.
      4. В Ports добавляем 2 интерфейса. Вначале LAN1. Затем wlan1.
      5. Идем в IP → DHCP Server → DHCP. Двойной клик по записи DHCP. И меняем интерфейс LAN1 на bridge1.
      6. Не забудьте, что в IP –> ARP динамически появятся записи с интерфейсом bridge1. Их сделайте статическими при необходимости. Старые записи на интерфейсе LAN1 — удалите. Во вкладке Interfaces – кликните по bridge1 и укажите Arp: reply-only, если нужна блокировка.
      7. Не забудьте в Tools → MAC-Server → WinBox добавить интерфейс bridge1, чтоб заходить через WinBox по MAC-у.
  9. Все. Теперь WiFi клиенты получат IP адреса из того же сегмента сети, что и проводные. В Wireless –> Registration – будут появляться все клиенты, которые подключены к вашей WiFi точке. Тут можно посмотреть их Tx/Rx скорости и пр. параметры.

VI. Пускаем нашу локалку в интернет.

  1. Идем в IP –> Firewall → NAT. По умолчанию NAT уже должен быть прописан.
  2. Если нету — то кликаем [+] → Chain –> srcnat.
  3. Out: Interface – интерфейс, который смотрит в интернет. Можно оставить пустым.
  4. Вкладка Action – masquerade.
  5. Все. Интернет настроен.
bystryj_start_-_dlja_gospod_so_svistkom.txt · Последние изменения: 2013/12/03 13:10 (внешнее изменение)
GNU Free Documentation License 1.3
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0 Яндекс.Метрика