Болкировка сайтов прокси-сервером

Вводная: Есть внешняя и внутренняя сеть, подключенные через Mikrotik. Надо заблокировать определенной группе устройств доступ на определенные сайты. При этом с остальных устройств доступ должен быть.

Реализация: Опишу решение двумя способами - через графический интерфейс Winbox и через консоль. Буду описывать одновременно оба - сначала описание и картинка, затем строка с аналогичной командой. Какой из них выбрать - на Ваше усмотрение.

  1. Включаем прокси(если он еще не включен). IP→Proxy
    /ip proxy set port=8080 enabled=yes
  2. Далее входим в Access (выделено желтым в п.1) и вводим адреса сайтов, которые необходимо заблокировать, как это показано на ниже
    ip proxy access add dst-host=*vk.com* action=deny

    Обратите внимание: в название сайта должно быть заключено в звездочки! Это говорит о том, что под это правило будут подпадать все строки, в которых встречается указанное назваине (в данном случае vk.com)

  3. Итак, мы имеем включенный прокси c правилом блокировки определенного узла. Теперь нам необходимо перенаправить нужный IP на proxy. Для этого идем в IP→Firewall→NAT и добавляем правило

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080

    Далее рассмотрим два варианта развития событий: болкируем доступ к сайтам с одного устройства, или с нескольких.

    1. Для одного устройства во вкладке General того же окна (Вы ведь не закрыли его, правда?) простодобавим параметр Src.Address=IP (к примеру 192.168.1.14)
    2. Для нескольких - создадим список устройств с ограниченным доступом: вкладка Advanced добавляем параметр Src.Address list=Block_List (сам Block_List сейчас будем наполнять)

      Заполняем наш Block_List: в нашем случае IP адреса клиенты получают с DHCP сервера mikrotik и за каждым MAC адресом статически забит конкретный IP адрес. В окне IP→DHCP-Server-Leases просто кликаем по клиенту в поле Address List вбиваем название нашего списка (в нашем случае это Block_List)

      Также можно в IP→FireWall→Address List создать вручную записи с привязкой нужного IP к нужному списку
      /ip firewall address-list add list=Block_List address=192.168.1.15
bolkirovka_sajtov_proksi-serverom.txt · Последние изменения: 2014/09/29 12:04 (внешнее изменение)
GNU Free Documentation License 1.3
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0 Яндекс.Метрика